跳转到主内容
帮助

当前版本: Darren Walker ,

标题:

No Power to Laptop with or without Battery

文本:

I've read numerous articles and suggestions about this issue but still can't get my Macbook to turn on.
-My Macbook won't power on nor will the battery charge. When I have a magsafe connected to the port Im getting a very very dim and flickering light. Here is everything I've tried.
+My Macbook won't power on nor will the battery charge. When I have a magsafe connected to the port Im getting a very very dim and flickering green light. Here is everything I've tried.
- Cleaning both the Magsafe and it's port. I've tried two different chargers with the no change.
- Resetting the SMC. Didn't do anything.
- Tried disconnecting the battery from the main board, powering on nothing. When I reconnected it still wouldn't charge or power on. I don't know a whole lot on how Mac's work but does a battery need to be installed when the power is plugged in? I had been getting a "Service battery" message. I don't want to purchase a new one if the board is toast obviously.
Im not sure what else I can try, doesn't seem like power is getting to the board. I did recently install a SSD and 8GB of Ram into the device to speed it up. Everything has been working just fine though for well over a week until this happened.
Any suggestions on something else I can try?

设备:

MacBook Pro 15" Unibody Mid 2009

状态:

open

原帖由: Darren Walker ,

标题:

No Power to Laptop with or without Battery

文本:

I've read numerous articles and suggestions about this issue but still can't get my Macbook to turn on.

My Macbook won't power on nor will the battery charge.  When I have a  magsafe connected to the port Im getting a very very dim and flickering light. Here is everything I've tried.

- Cleaning both the Magsafe and it's port.  I've tried two different chargers with the no change.

- Resetting the SMC.  Didn't do anything.

- Tried disconnecting the battery from the main board, powering on nothing.  When I reconnected it still wouldn't charge or power on.  I don't know a whole lot on how Mac's work but does a battery need to be installed when the power is plugged in?  I had been getting a "Service battery" message.  I don't want to purchase a new one if the board is toast obviously.

Im not sure what else I can try, doesn't seem like power is getting to the board.  I did recently install a SSD and 8GB of Ram into the device to speed it up.  Everything has been working just fine though for well over a week until this happened.

Any suggestions on something else I can try?

设备:

MacBook Pro 15" Unibody Mid 2009

状态:

open