跳转到主内容
帮助

当前版本: oldturkey03 (投票详情) ,

标题:

MacBook Power Issue - Charger or Battery?

文本:

Hi,

Recently my friend gave me his old Macbook as he got a new MacBook Pro. It is the white A1342 model from 2009 I believe. He dropped it on the corner where the MagSafe charging port is and from then on the unit wouldn't recognize a charger and wouldn't power on. Being fairly technically minded and competent in fixing iPhones I decided to branch out and use this opportunity to broaden my repair knowledge of Apple products. I ordered a pre-owned MagSafe board off eBay, replaced the part, and got it to work again. I didn't have a charger so purchased a 3rd party one for $20 off eBay....it worked fine for about 3/4 months and I was really happy with it.

The other day I had the charger plugged into an extension cable that ran to the wall, and the other end plugged in and charging the macbook. It was one of those cheap extension cables, the kind you can get at Walmart for about $2. I noticed the plug part of the charger was starting to get hot. The bottom of the Macbook was also getting hot, so I unplugged it from the extension cable to allow it to cool down. It worked fine for another day or two, but when I came to it one morning it wouldn't "wake up" from the sleep mode and it wouldn't power on by pressing the button. I also had problems connecting the charger to the unit. Usually, the small light would show up red to indicate it was charging, and eventually turn green once fully charged. I couldn't get the charger to connect and fiddled around connecting it and re-connecting it in different ways until eventually the small light showed up red. I opened the lid, pressed the power button and the unit booted up just as it had before and I started using it again.....only this time the battery icon at the top said "Not Charging" next to it. It sometimes did that very briefly when first connecting a charger, maybe 2 or 3 seconds before it switched to the % amount and started charging properly. However, this time it just displayed the not charging text, despite the backlight behaving the same when I unplugged and re-plugged the charger (unplugged and the backlight darkened slightly, re-connected it and the backlight brightened to indicate the charger was attached).

I kept an eye on it for a day or two and now the Macbook fails to power on at all, even though I've connected the charger and the red light is visible. I'm assuming this means the unit is getting power but I'm still not really sure what could be going on. At first I was thinking that the cheap charger had eventually met it's demise and I would have to stump up for a proper one, but now I'm thinking maybe the battery has finally gone for good. I read a few articles on here that suggested disconnecting the battery and holding the power button for 5 seconds, and I've also tried to reset the SMC (not sure whether the unit has to be powered on for that). I've tried both of these to no avail. Did maybe the heat I mentioned earlier damage something inside?

Sorry for the long-winded post, I just think it's best to be thorough when describing stuff to give people all the details. I live too far from an Apple store for a visit to be feasible, and I doubt with the age of the machine any repairs by them would be financially viable. Any information and help on this would be greatly appreciated!

Thanks,

Brendan

设备:

MacBook Unibody Model A1342

状态:

open

已接受的回答:

158655

原帖由: BLedge ,

标题:

MacBook Power Issue - Charger or Battery?

文本:

Hi,

Recently my friend gave me his old Macbook as he got a new MacBook Pro. It is the white A1342 model from 2009 I believe. He dropped it on the corner where the MagSafe charging port is and from then on the unit wouldn't recognize a charger and wouldn't power on. Being fairly technically minded and competent in fixing iPhones I decided to branch out and use this opportunity to broaden my repair knowledge of Apple products. I ordered a pre-owned MagSafe board off eBay, replaced the part, and got it to work again. I didn't have a charger so purchased a 3rd party one for $20 off eBay....it worked fine for about 3/4 months and I was really happy with it.

The other day I had the charger plugged into an extension cable that ran to the wall, and the other end plugged in and charging the macbook. It was one of those cheap extension cables, the kind you can get at Walmart for about $2. I noticed the plug part of the charger was starting to get hot. The bottom of the Macbook was also getting hot, so I unplugged it from the extension cable to allow it to cool down. It worked fine for another day or two, but when I came to it one morning it wouldn't "wake up" from the sleep mode and it wouldn't power on by pressing the button. I also had problems connecting the charger to the unit. Usually, the small light would show up red to indicate it was charging, and eventually turn green once fully charged. I couldn't get the charger to connect and fiddled around connecting it and re-connecting it in different ways until eventually the small light showed up red. I opened the lid, pressed the power button and the unit booted up just as it had before and I started using it again.....only this time the battery icon at the top said "Not Charging" next to it. It sometimes did that very briefly when first connecting a charger, maybe 2 or 3 seconds before it switched to the % amount and started charging properly. However, this time it just displayed the not charging text, despite the backlight behaving the same when I unplugged and re-plugged the charger (unplugged and the backlight darkened slightly, re-connected it and the backlight brightened to indicate the charger was attached).

I kept an eye on it for a day or two and now the Macbook fails to power on at all, even though I've connected the charger and the red light is visible. I'm assuming this means the unit is getting power but I'm still not really sure what could be going on. At first I was thinking that the cheap charger had eventually met it's demise and I would have to stump up for a proper one, but now I'm thinking maybe the battery has finally gone for good. I read a few articles on here that suggested disconnecting the battery and holding the power button for 5 seconds, and I've also tried to reset the SMC (not sure whether the unit has to be powered on for that). I've tried both of these to no avail. Did maybe the heat I mentioned earlier damage something inside?

Sorry for the long-winded post, I just think it's best to be thorough when describing stuff to give people all the details. I live too far from an Apple store for a visit to be feasible, and I doubt with the age of the machine any repairs by them would be financially viable. Any information and help on this would be greatly appreciated!

Thanks,

Brendan

设备:

MacBook Unibody Model A1342

状态:

open