跳转到主内容
帮助

当前版本: mayer (投票详情) ,

标题:

iMac screen won't light up after HDD replacement

文本:

This is the iMac 11,2 with a 3.2GHz processor

Followed [guide|6284|this guide] to replace a failing HDD.

When I reassembled the iMac and booted up, I got a grey screen followed by vertical colored stripes.  So I took the machine back apart and found two bent pins on the data display cable, and that it's retaining clip was loose.  Smoothed out the pins, and plugged it back into the board without incident.

Unfortunately, now there's no LED backlight coming on and nothing at all on the display.  Not much of an improvement, there.

I saw in the comments on the HDD replacement guide that a loose LCD thermal sensor cable connector could be the cause, but that doesn't seem to be the case.

Any advice on what to try next?

设备:

iMac Intel 21.5" EMC 2389

状态:

open

已接受的回答:

131785

编辑: originalmachead ,

标题:

iMac screen won't light up after HDD replacement

文本:

This is the iMac 11,2 with a 3.2GHz processor

Followed [guide|6284|this guide] to replace a failing HDD.

When I reassembled the iMac and booted up, I got a grey screen followed by vertical colored stripes.  So I took the machine back apart and found two bent pins on the data display cable, and that it's retaining clip was loose.  Smoothed out the pins, and plugged it back into the board without incident.

Unfortunately, now there's no LED backlight coming on and nothing at all on the display.  Not much of an improvement, there.

I saw in the comments on the HDD replacement guide that a loose LCD thermal sensor cable connector could be the cause, but that doesn't seem to be the case.

Any advice on what to try next?

设备:

iMac Intel 21.5" EMC 2389

状态:

open

原帖由: keithkeller ,

标题:

iMac screen won't light up after HDD replacement

文本:

This is the iMac 11,2 with a 3.2GHz processor

Followed [guide|6284|this guide] to replace a failing HDD.

When I reassembled the iMac and booted up, I got a grey screen followed by vertical colored stripes.  So I took the machine back apart and found two bent pins on the data display cable, and that it's retaining clip was loose.  Smoothed out the pins, and plugged it back into the board without incident.

Unfortunately, now there's no LED backlight coming on and nothing at all on the display.  Not much of an improvement, there.

I saw in the comments on the HDD replacement guide that a loose LCD thermal sensor cable connector could be the cause, but that doesn't seem to be the case.

Any advice on what to try next?

设备:

iMac Intel 21.5" EMC 2389

状态:

open