跳转到主内容
帮助

当前版本: originalmachead and oldturkey03 (投票详情) ,

标题:

I replaced logicboard but the ethernet doesn't always work.

文本:

I bought a liquid damaged macbook (a1342 2009) and also from someone else a logic board. I succesfully replaced the logic board with the other one, and it booted again. I now type this from that Macbook.

However, I made sure to test everything, and my ethernet won't work. It always says "Cable Unplugged", also when plugged in. When I put the cable into my original macbook, it immediately connects ok, so the cable is fine.

I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?) What could I try to get it working?

I do run OSX 10.7, so the mac should be supported fully.

==Update==

I tried another network cable, and suddenly it did work. But after I wiggle a tiny bit with that cable the connection gets lost, and I need to plug out and plug in again. So still not really working as it should. On my original Macbook, this would not cause disconnection.

设备:

MacBook Unibody Model A1342

状态:

open

已接受的回答:

131008

编辑: Peterdk ,

标题:

I replaced logicboard but the ethernet doesn't always work. Can it be fixed?
I replaced logicboard but the ethernet doesn't always work. Can it be fixed?

文本:

I bought a liquid damaged macbook (a1342 2009) and also from someone else a logic board. I succesfully replaced the logic board with the other one, and it booted again. I now type this from that Macbook.

However, I made sure to test everything, and my ethernet won't work. It always says "Cable Unplugged", also when plugged in. When I put the cable into my original macbook, it immediately connects ok, so the cable is fine.

I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?) What could I try to get it working?

I do run OSX 10.7, so the mac should be supported fully.

==Update==

I tried another network cable, and suddenly it did work. But after I wiggle a tiny bit with that cable the connection gets lost, and I need to plug out and plug in again. So still not really working as it should. On my original Macbook, this would not cause disconnection.

设备:

MacBook Unibody Model A1342

状态:

open

编辑: Peterdk ,

标题:

I replaced logicboard but the ethernet doesn't work. Can it be fixed?

文本:

I bought a liquid damaged macbook (a1342 2009) and also from someone else a logic board. I succesfully replaced the logic board with the other one, and it booted again. I now type this from that Macbook.
 
However, I made sure to test everything, and my ethernet won't work. It always says "Cable Unplugged", also when plugged in. When I put the cable into my original macbook, it immediately connects ok, so the cable is fine.
 
I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?) What could I try to get it working?
 
I do run OSX 10.7, so the mac should be supported fully.
 
==Update==
I
I
tried another network cable, and suddenly it did work. But after aI wiggle a tiny bit with that cable the connection gets lost, and I need to plug out and plug in again. So still not really working as it should. On my original Macbook, this would not cause disconnection.
I
I
tried another network cable, and suddenly it did work. But after aI wiggle a tiny bit with that cable the connection gets lost, and I need to plug out and plug in again. So still not really working as it should. On my original Macbook, this would not cause disconnection.

设备:

MacBook Unibody Model A1342

状态:

open

编辑: Peterdk ,

标题:

I replaced logicboard but the ethernet doesn't work. Can it be fixed?

文本:

I bought a liquid damaged macbook (a1342 2009) and also from someone else a logic board. I succesfully replaced the logic board with the other one, and it booted again. I now type this from that Macbook.
 
However, I made sure to test everything, and my ethernet won't work. It always says "Cable Unplugged", also when plugged in. When I put the cable into my original macbook, it immediately connects ok, so the cable is fine.
 
I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?) What could I try to get it working?
 
I do run OSX 10.7, so the mac should be supported fully.
 
==Update==
I tried another network cable, and suddenly it did work. But after a wiggle a tiny bit with that cable the connection gets lost, and I need to plug out and plug in again. So still not really working as it should.

设备:

MacBook Unibody Model A1342

状态:

open

编辑: Peterdk ,

标题:

I replaced logicboard but the ethernet doesn't work. My faultCan it be fixed?
I replaced logicboard but the ethernet doesn't work. My faultCan it be fixed?

文本:

I bought a liquid damaged macbook (a1342 2009) and also from someone else a logic board. I succesfully replaced the logic board with the other one, and it booted again. I now type this from that Macbook.
 
However, I made sure to test everything, and my ethernet won't work. It always says "Cable Unplugged", also when plugged in. When I put the cable into my original macbook, it immediately connects ok, so the cable is fine.
 
I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?) What could I try to get it working?
I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?) What could I try to get it working?
 
I do run OSX 10.7, so the mac should be supported fully.

设备:

MacBook Unibody Model A1342

状态:

open

原帖由: Peterdk ,

标题:

I replaced logicboard but the ethernet doesn't work. My fault?

文本:

I bought a liquid damaged macbook (a1342 2009) and also from someone else a logic board. I succesfully replaced the logic board with the other one, and it booted again. I now type this from that Macbook.

However, I made sure to test everything, and my ethernet won't work. It always says "Cable Unplugged", also when plugged in. When I put the cable into my original macbook, it immediately connects ok, so the cable is fine.

I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?)

I do run OSX 10.7, so the mac should be supported fully.

设备:

MacBook Unibody Model A1342

状态:

open