跳转到主内容
帮助

当前版本: jamesgid ,

标题:

No signal after screen repair, Searching... NEW

文本:

Hi All, I am a phone repairer who has fixed over 3000 iphone 4/4s phones.
In the last 2 weeks, almost every single 4S I have repaired (using the same aftermarket parts I have always sourced) the phone is now showing Searching... when the phone is turned back on.
I have had some that show the following:
Searching.... 3G
And they actually have signal, but no showing of bars or signal strength.
Others show the following
Searching....
And do not have reception at all. Removing the sim card and tray does not even generate the 'No sim card' message. So it is almost like the phone does not even recognise the sim card is installed.
I have come across a couple of work around solutions to get the signal back.
1. Start phone with no sim tray. Once phone is booted insert sim tray. This has only worked maybe once or twice.
2. Start the phone with an invalid sim (from another carrier). The phone then recognizes this invalid sim and asks the phone to be activated. I can then remove the invalid sim, put in the correct sim, it prompts for the sim lock. Once sim lock is cleared phone is back to normal.
3. Boot phone with sim in, get Searching... message. Turn on and connect to a Wifi signal, then remove the sim. No sim message appears. Re-insert sim, it prompts for sim lock. Once sim lock code entered phone is fine.
It almost seems as though if the sim has a lock, the phone is not bringing up the 'Sim Locked, Unlock' message. Most of the workarounds I have found produce the "Sim Locked" message after the procedure that then allows reception again.
From what I can tell, all of these phones have IOS 6.0 or later and Modem 3.0.04
I would like to know what is causing this and how to more quickly resolve this issue.
Have any other repairers been having these issues?
Thanks in advance.
+
+== Update ==
+
+As the original poster of this thread I have to say that after seeing this issue over and over again (easily more than 100 iphones) I can say that whenever there is a service issue, simply setting the correct date and time will restore service. Sometimes the phone needs to be rebooted twice, but most of the time one reboot is fine. If there is a sim pin, that will complicate the process. Usually when there is a sim pin it takes longer for the phone to recognise the sim and give you the sim pin prompt. But again, it always comes good.
+
+Now if the phone had signal issues before the phone was repaired, then you will continue to have issues after a screen replacement. They are not directly linked at all. Also, there are lots of issues with carrier locked phones and stolen phones. I have people all the time come in to have a phone repaired that they 'just bought cheap of ebay' or 'just bought cheap of a friend of a friend'. We repair, and then they go and chuck any old sim at it and expect it to work. When it doesn't they assume it is our fault the phone is 'broken' and not working. So be careful with signal issues, the problem can be for many varying reasons.

设备:

iPhone 4S

状态:

open

已接受的回答:

117482

编辑: jamesgid ,

标题:

No signal after screen repair, Searching... NEW

文本:

Hi All, I am a phone repairer who has fixed over 3000 iphone 4/4s phones.

In the last 2 weeks, almost every single 4S I have repaired (using  the same aftermarket parts I have always sourced) the phone is now showing Searching... when the phone is turned back on.

I have had some that show the following:

Searching.... 3G

And they actually have signal, but no showing of bars or signal strength.

Others show the following

Searching....

And do not have reception at all. Removing the sim card and tray does not even generate the 'No sim card' message. So it is almost like the phone does not even recognise the sim card is installed.

I have come across a couple of work around solutions to get the signal back.

1. Start phone with no sim tray. Once phone is booted insert sim tray. This has only worked maybe once or twice.

2. Start the phone with an invalid sim (from another carrier). The phone then recognizes this invalid sim and asks the phone to be activated. I can then remove the invalid sim, put in the correct sim, it prompts for the sim lock. Once sim lock is cleared phone is back to normal.

3. Boot phone with sim in, get Searching... message. Turn on and connect to a Wifi signal, then remove the sim. No sim message appears. Re-insert sim, it prompts for sim lock. Once sim lock code entered phone is fine.

It almost seems as though if the sim has a lock, the phone is not bringing up the 'Sim Locked, Unlock' message. Most of the workarounds I have found produce the "Sim Locked" message after the procedure that then allows reception again.

From what I can tell, all of these phones have IOS 6.0 or later and Modem 3.0.04

I would like to know what is causing this and how to more quickly resolve this issue.

Have any other repairers been having these issues?

Thanks in advance.

设备:

iPhone 4S

状态:

open

已接受的回答:

+117482

原帖由: jamesgid ,

标题:

No signal after screen repair, Searching... NEW

文本:

Hi All, I am a phone repairer who has fixed over 3000 iphone 4/4s phones.

In the last 2 weeks, almost every single 4S I have repaired (using  the same aftermarket parts I have always sourced) the phone is now showing Searching... when the phone is turned back on.

I have had some that show the following:

Searching.... 3G

And they actually have signal, but no showing of bars or signal strength.

Others show the following

Searching....

And do not have reception at all. Removing the sim card and tray does not even generate the 'No sim card' message. So it is almost like the phone does not even recognise the sim card is installed.

I have come across a couple of work around solutions to get the signal back.

1. Start phone with no sim tray. Once phone is booted insert sim tray. This has only worked maybe once or twice.

2. Start the phone with an invalid sim (from another carrier). The phone then recognizes this invalid sim and asks the phone to be activated. I can then remove the invalid sim, put in the correct sim, it prompts for the sim lock. Once sim lock is cleared phone is back to normal.

3. Boot phone with sim in, get Searching... message. Turn on and connect to a Wifi signal, then remove the sim. No sim message appears. Re-insert sim, it prompts for sim lock. Once sim lock code entered phone is fine.

It almost seems as though if the sim has a lock, the phone is not bringing up the 'Sim Locked, Unlock' message. Most of the workarounds I have found produce the "Sim Locked" message after the procedure that then allows reception again.

From what I can tell, all of these phones have IOS 6.0 or later and Modem 3.0.04

I would like to know what is causing this and how to more quickly resolve this issue.

Have any other repairers been having these issues?

Thanks in advance.

设备:

iPhone 4S

状态:

open